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RESUMO

O presente tutorial pretende abordar os processos de criação e
implementação dos sons para um Audio Game, jogo eletrônico
constituı́do exclusivamente por recursos sonoros, perpassando por
processos de Composição musical, Sound Design e Programação.

Palavras-chave: Audio Game, Áudio Dinâmico, Fmod Studio.

1 INTRODUÇÃO

O tutorial foi projetado com 4 diferentes camadas de áudio, das
quais possuem funções especı́ficas e complementares, buscando
oferecer uma experiência sonora mais imersiva. Locuções: As
locuções têm como objetivo contar a narrativa do jogo para o jo-
gador. Dado o fato de haver somente recursos sonoros em um Au-
dio Game, não poderão ser observadas as expressões faciais dos
atores-locutores. Portanto, torna-se necessária uma maior ênfase
nas interpretações dos diálogos gravados entre os personagens.
Efeitos sonoros: Os efeitos sonoros possuem a função de estabe-
lecer a interação do jogador com os diferentes objetos que compõe
os cenários do jogo. Assim como auxiliar no senso de direção do
personagem ao posicionar objetos emissores de som como rádio,
chaleiras no fogo etc, servindo como pontos de referência auditi-
vos para o jogador. Ambiências: As ambiências contribuem com a
contextualização e identificação do cenário em que o jogador se en-
contra através da criação de uma “paisagem sonora”. Dessa forma
pode se representar e delimitar acusticamente um ambiente como de
uma floresta, por exemplo, criando e implementando-se no cenário
do jogo sons de vento, farfalhar de folhas, sons de pássaros etc.
Trilha Sonora: Por fim, a trilha sonora cumpre as funções de repre-
sentar o sentimento do personagem e de apresentar um sistema de
localização, direcionando o jogador ao seu objetivo final.

2 DOWNLOAD E INSTALAÇÃO
Vá até a página http://www.fmod.org/download e escolha a opção
condizente com seu sistema operacional e realize a instalação se-
guindo os passos necessários.

3 CRIAÇÃO DE UM NOVO PROJETO NO FMOD STU-
DIO

O FMOD Studio segue uma lógica semelhante à de outros softwa-
res comumente utilizados em um computador. Para criar um novo
arquivo basta ir à barra de menu e clicar em: File > New. No en-
tanto, quando executamos o FMOD, já é criado um novo projeto,
logo, bastaria salvá-lo no local desejado usando o caminho: File
> Save, ou utilizar o comando Ctrl + S. Nesse tutorial, usaremos
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algumas nomenclaturas em inglês, próprias da interface do progra-
mas. Apresentaremos em seguida alguns dos elementos principais
da interface, aos quais faremos referência constantemente.

3.1 Event Browser

Esta é a área na qual nós iremos criar os eventos, podendo organizá-
los por pastas.

Figura 1: Event Browser

3.2 Event Editor

Aqui nós temos a Timeline e os parâmetros do eventos. A estru-
tura do Event Editor se assemelha à estrutura de uma programa
de edição de áudio, pela presença de uma timeline e pelas pis-
tas de áudio. Aqui nós iremos criar a estrutura lógica dos even-
tos. A região Logic Tracks, é onde nós definiremos áreas de loop,
transições, etc. Veja um exemplo abaixo:

Figura 2: Event Editor

3.3 Deck

Sempre que selecionamos um elemento no Event Editor, apare-
cerão propriedades referentes a ele no Deck. Por exemplo, em um
módulo de áudio podemos configurar propriedades como Pitch, vo-
lume e configurações de espacialização. Esta região possui duas
abas: Uma que determina parâmetros especı́ficos do elemento se-
lecionado e a aba Event Macros, que determinam parâmetos gerais
do evento.
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Figura 3: Deck

3.4 Audio Bin

É onde importamos e organizamos os arquivos de áudio que serão
utilizados no projeto, é acessı́vel pelo menu Window>Audio Bin,
ou pelo atalho Ctrl+3. Aqui podemos criar pastas para agrupar ar-
quivos de áudio.

3.5 Mixer

Na janela de Mixer podemos ajustar nı́veis de volume dos eventos,
criando grupos de eventos e também é possı́vel criar Snapshots.
Comentaremos mais sobre eles adiante. Esta janela é acessı́vel pelo
menu Window>Mixer, ou pelo atalho Ctrl+2.

Figura 4: Mixer

3.6 Importar áudio

Vá ao menu Window>Audio Bin, ou use as teclas de atalho Ctrl +
3, para abrir a janela onde os áudios serão importados. Clique no
menu File > Import Audio, ou use o atalhe de teclado Ctlr+Shift+I
e selecione os áudios que serão importados. Uma vez que esses
áudios estejam no Audio Bin, eles podem ser utilizados no pro-
jeto, clicando e arrastando esses áudios para os eventos. Também
é possı́vel importar áudios para o projeto usando, clicando e arras-
tando direto das pastas de seu computador para os eventos, ou nos
locais onde aparece a opção: Drop audio files here.

3.7 Criar um novo evento

Para criar um novo evento, clique com o botão direito no Event
Browser e escolha a opção New Event. Note que também é possı́vel
criar pastas para agrupar seus eventos, para isso basta clicar com o
botão direito e escolher a opção New Folder. Para agrupar os even-
tos, basta clicar e arrastar para dentro da pasta. Se quiser renomear
seus eventos e pastas, basta dar um duplo clique, escrever o nome
desejado e apertar a tecla Enter.

3.8 Pistas

Todo evento, quando criado, possui duas pistas, por padrão. A pista
Audio 1 e a pista Master. Para criar novas pistas, basta clicar com
o botão direito sobre a pista Audio 1, na região onde aparece o
nome da pista e selecione a opção Add Audio Track, como vemos
na figura 5. Para renomear suas pistas, basta clicar duas vezes sobre
o nome

3.9 Módulos de som

Os módulos de som são a forma como o arquivo de áudio é execu-
tado dentro do evento; cada um deles funcionará de maneira dife-
rente. Eles são representados por dois componentes, o Sound Mo-
dule no Deck, e a sua Trigger Region, na timeline.

Figura 5: Criando nova pista

4 AMBIÊNCIAS
Para a criação de ambiência nesse jogo, precisamos determinar que
sons serão ouvidos pelo jogador. Lembrando que todo som ser-
virá de referência para a localização, uma vez que não possuı́mos
imagens. Neste caso, o personagem se encontra em um quarto, no
qual existe uma janela. A casa do jogador está situada em uma área
pouco urbanizada com presença de vasta vegetação, logo é natural
que tenhamos sons da natureza vindo pela janela. Ou seja, temos
uma ambiência externa. Além desta, temos a ambiência do quarto,
o que chamamos de room tone, que é o som natural da sala, resul-
tado de reflexões sonoras, ruı́dos estruturais. Então criaremos dois
eventos: external e room.

4.1 Evento external
Este evento será emitido pelo objeto da janela, quando formos inte-
grar no Unity 3D. Na janela do quarto do personagem há um men-
sageiro dos ventos, logo, este é um dos sons que são emitidos pela
janela. Nosso evento é formado de quatro pistas:

• AmbEXT-L

• AmbEXT-R

• AmbEXT-BG

• Chimes

As duas primeiras pistas contêm o som de uma gravação de am-
biente externo, como sons de pássaros, sons de vento e veı́culos
muito distantes, gravados em um ambiente pouco urbanizado. A
terceira é possui uma gravação de um ambiente externo captado em
uma região de mata. Na quarta pista, temos o som do mensageiro
dos ventos. Cada um desses áudios deve ser inserido nas pistas
clicando e arrastando o áudio do Audio Bin para a pista.

No Deck, selecione a opção de loop, nas opções do módulo de
som, isso deve ser feito com cada um dos áudios.

Figura 6: Criando loops de áudio

Para criar um o ambiente de nosso universo sonoro, misturamos
estes dois ambientes para criar um terceiro. Colocamos o primeiro
totalmente à esquerda no panorama na primeira pista, totalmente
à direita na segunda pista e o segundo som no centro, na terceira
pista. Para isso, nós configuramos no deck de cada módulo o seu
output como Stereo e definimos o pan, fazemos isso para cada pista.
Vemos este processo na figura 7.
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Figura 7: Criando um ambiente sonoro

Para a pista chimes, nós iremos criar uma automação de volume,
para simular o efeito do vento, pois, se deixássemos o volume con-
tante, soaria como se o vento fosse ininterrupto, então, iremos criar
automações para que às vezes soe mais baixo, mais alto, ou não
soe, como se o vento fosse mais fraco, mais forte ou inexistente.
Clique com o botão direito sobre o knob de volume e selecione a
opção Add Automation. Uma nova subspista aparecerá abaixo da
pista chimes. Desenhe a automação conforme a imagem.

Figura 8: Automação de volume

Na região Logic Tracks, clique com o botão direito e selecione a
opção Add Loop Region.

Figura 9: Criando Loop Region

Uma nova região de loop será criada. Posicione-a, clicando e
arrastando, um pouco após o inı́cio da timeline (dois segundos).
Clique e arraste o final da região para aumentá-la até o fim de seus
módulos de som. Desta forma:

Figura 10: Ajustando região de loop

Na pista Master, crie uma automação de volume, indo do começo
da timeline até o começo da região de loop. Indo de -80.00 dB até
0.00 dB. Com isso, haverá um fade in no começo do evento, para
que não comece bruscamente. Quando iniciar a região de loop, esse
fade in não será executado.

4.2 Evento room
Para este evento usaremos um áudio de room tone. Este áudio será
adicionado na pista, conforme os demais, e iremos criar uma região
de loop e um fade in na pista Master da mesma forma como no
evento anterior. Em relação ao panorama, deixaremos este evento
no centro. Um detalhe deste evento, é que ele não será emitido por

nenhum objeto, ele deve ser ouvido em qualquer local do ambiente,
sem espacialização. Para isso, iremos transformá-lo em um som
2D, para isso, vá ao Deck da pista Master e exclua o componente
de 3D Panner, conforme a imagem abaixo:

Figura 11: Excluindo o 3D Panner

5 LOCUÇÕES
Este evento será disparado toda vez que o personagem passar pela
mesa de trabalho, no quarto. Na primeira vez, ouviremos uma
locução, “Talvez seja melhor trabalhar um pouco”, e em seguida,
ouviremos ele sentar na cadeira, e digitar um pouco, e então ele
dirá “Não, não consigo me concentrar, melhor ir checar chaleira”.
Na segunda vez, ele irá esbarrar e dizer “Isso vai deixar marcar”,
a partir da terceira vez ele irá apenas esbarrar e ouviremos uma
interjeição de dor e o esbarrar na cadeira.

• Para isso, iremos criar primeiramente o evento cadeira, ao
lado da aba timeline, clicamos no + escolhemos a opção Add
Parameter. Nomeie esse paramêtro como vez-cadeira, colo-
que seu mı́nimo em 0 e o máximo em 3.

• Na pista Audio 1, na posição 0, clique com o botão direito
e escolha a opção New Event Sound. Um novo evento será
criado dentro do evento cadeira. Renomeie-o como cadeira-
vez1. Neste evento iremos criar as pistas Locução, Cadeira
(na qual haverá o som de arrastar a cadeira) e Teclado (na qual
haverá o som de digitação no teclado). Organize os arquivos
de áudio como na imagem:

Figura 12: Organização dos arquivos de áudio

• Volte para o evento cadeira.

• Crie duas novas pistas.

• Na primeira pista, na posição 1, coloque o crie um módulo
Single Sound (clique com o botão direito>Add Single Sound)
, no Deck, coloque o áudio da locução correspondente, onde
está escrito Drop audio file here.

Figura 13: Colocação dos áudios de locução
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• Na segunda pista, na mesma posição, crie um Single Sound e
associe o som de esbarrar.

• Na terceira pista, ainda na posição 1, crie um módulo Mult
Sound (botão direito>Add Multi Sound). E associe, no deck
os arquivos referentes à movimentação da cadeira.

• Na posição 2, na primeira pista, crie um Multi Sound com as
interjeições de dor.

• Na segunda pista, na posição 2, coloque o som de esbarrar
com um Single Sound.

• Na terceira pista, crie um Mult Sound com os sons de
movimentação da cadeira.

Figura 14: Posicionamento módulos Multi Sound

6 PERCEPÇÃO ACÚSTICA
Este evento foi criado para simular um fenômeno acústico. O obje-
tivo é dar mais uma dica de localização para o jogador. Nos cantos,
de uma sala, por haver uma convergência de reflexões sonoras, te-
mos um reforço de frequências baixas. Ou seja, temos a sensação
de ouvir um ganho de graves. Pra isso, criaremos um snapshot, no
qual, definiremos um ganho de graves em todos os eventos do jogo,
com exceção do evento de música. Um snapshot permite que um
estado dentro do Mixer seja salvo, como volume, mandadas de um
canal ou configurações de um efeito (equalizador, compressor, etc.).
Desta forma, esses valores podem sobrescrever os valores originais.
Para isso, vamos abrir o Mixer e criar grupos de eventos, separando
música e demais eventos.

• No canto direito da tela, como na figura 15 selecione os even-
tos de música, clique com o botão direito e escolha a opção:
Reroute into New Group. Dê dois cliques no nome do grupo e
o nomeie como Música. Faça o mesmo com os demais even-
tos, nomeando este grupo como Eventos.

Figura 15: Criando novos grupos no Mixer

• Na área Mixing Desk, na figura 16 onde aparecem as pistas
de áudio, selecione a pista Eventos, seguida, no Deck, clique
no área onde há o sı́mbolo de +, à direita do knob de volume,
selecione a opção Add Effect e, em seguida, escolha FMOD
3-EQ.

Figura 16: Adicionando Equalizador

• Clique na aba Snapshot, clique com o botão direito e escolha
a opção: New Overriding Snapshot.

• Selecione o canal eventos, no Deck, clique no knob low com
o botão direito e selecione a opção Scope In.

Figura 17: Aumentando ganho na banda grave do Equalizador

• Dê um ganho de +6dB.

• Volte à janela do Event Editor, crie um novo evento e, ao lado
da aba timeline, clique no + e selecione a opção Add Parame-
ter. Nomeie-o.

• Na pista Audio 1, como na figura 18, clique com o botão di-
reito e escolha a opção Add Snapshot e escolha o snapshot que
acabou de criar. Estique o módulo para que ele vá do valor 0
até 1, dentro do parâmetro.

Figura 18: Criando Snapshot

• Selecione o módulo e, no Deck, clique com o botão direito
no knob Intensity e escolha a opção Add Automation, como
visto na figura 19.

• Crie um automação de volume que varie de de -80dB, no
inı́cio do parâmetro até 0dB.
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Figura 19: Criando Automação

7 MÚSICA
Oferecer um feedback claro de direção ao jogador sem recurso vi-
sual é um desafio. A solução mais óbvia pode ser o uso de locuções.
Porém, que este recurso já esta cumprindo o papel em contar a
narrativa do jogo, foram experimentadas técnicas de adaptabili-
dade na composição musical, onde as ações do jogador poderiam
interferir na trilha sonora em tempo real. A ideia foi criar uma
implementação de áudio onde, conforme o jogador for se alinhando
em direção ao seu objetivo, instrumentos musicais vão sendo adici-
onados. O gráfico da figura 20 à seguir demonstra essa abordagem.

Figura 20: Feedback de direção e instrumentos musicais

Para a implementação da trilha sonora seguindo essa lógica de
auxiliar no direcionamento e proximidade do jogador ao seu obje-
tivo, siga os seguintes passos:

• Crie um evento denominado “music”.

• Dentro deste evento crie 7 canais de áudio denominados como
“Tag-saida-sala”, “Stinger-vibraf”, “Piano”, “Vln 1”, “Vln 2”,
“Viola” e “Cello”. Para a criação desses 6 canais adicionais,
basta clicar com o botão direito do mouse em qualquer um
dos canais criados e selecionar no menu que aparecerá a opção
“Add Audio Track”. Repita esse processo de criação de canais
e nomeando cada um até ter os 6 canais necessários.

• Você deverá importar os arquivos de áudio contidos na pasta
Asset, no caminho: Breu > Breu-FMOD>Assets. Os arqui-
vos a serem importados são: “Camada Cello”, “Camada Pi-
ano”, “Camada Viola”, “Camada Vln 1”, “Camada Vln 2”,
“Tag acerto Piano”, “Stinger-dir-1”, “Stinger-dir-2”, “Stinger-
dir-3” e “Stinger-dir-4”. Selecione os 10 arquivos e os arraste
para a aba “Assets” do projeto no FMOD.

Figura 21: Importando arquivos de áudio da trilha sonora.

• Selecione cada arquivo e arraste para seu respectivo canal
através da indicação de seu instrumento. Ex.: “Camada
Cello” para o canal “Cello” e assim por diante, até atingir o
resultado abaixo:

Figura 22: Posicionamento dos arquivos nos canais de áudio.

• À excessão do “Stinger-saı́da-sala”, todos os outros even-
tos de áudio devem estar em loop contı́nuo quando tocados.
Então clique em cada canal e, em sua janela de inspector cli-
que no ı́cone de loop. O módulo se transformará no retângulo
azul, assim como mostrado na figura abaixo.

Figura 23: Acionando o loop dos módulos.

• Posicione cada evento de áudio em entradas sucessivas. Para
isso, clique no interior de cada evento com o botão esquerdo
do mouse e, mantendo-o pressionado, arraste para a posição
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desejada. Para aumentar seu tamanho clicando na borda di-
reita do evento e arraste até atingir o tamanho desejado. Pro-
cure seguir a seguinte ordem: “Camada Cello”, “Camada Vi-
ola”, “Camada Vln 2”, “Camada Vln 1”, “Camada Piano” e
“Tag-saı́da-sala”. Os 4 trechos de “Stinger-dir” são posicio-
nados alinhados ao inı́cio dos 4 primeiros eventos, conforme
demonstrado na figura abaixo.

Figura 24: Posicionamento dos Stingers com módulos de som.

• Crie então um Marker, clicando com o botão direito na área
preta logo abaixo da Timeline, selecionando a opção Add
Marker.

Figura 25: Adicionando Markers.

• Em seguida, dê um duplo clique no nome Marker A e no-
meie para “Cello”. Repita o processo criando mais 12 mar-
kers nomeados e posicionados sucessivamente como: “Vi-
ola”, “Viola-volta”, “trans-Cello”, “Vln 2”, “Vln 2-volta”,
“trans-Viola”, “Vln 1”, “Vln 2-volta”, “trans-Vln 2”, “Piano”,
“trans-Vln 1” e “Saı́da-sala”.

Figura 26: Nomeando Markers.

• Deverão ser criados 5 Loop regions próximo aos markers de
cada instrumento: “Cello”, “Viola”, “Vln 2”, “Vln 1” e “Pi-
ano”, conforme demonstrado abaixo:

Figura 27: Posicionamento de Loop Regions.

• À seguir deverão ser criados dois parâmetros para determinar
o ângulo de direção e a proximidade em relação ao objetivo
final - sair da sala. Para se criar novos parâmetro no FMOD
Studio, clique na aba “+” ao lado da aba “Timeline”. Em se-
guida clique na opção “Add Parameter” no menu que se abrirá.
Para a criação do evento de Ângulo de Direção, digite “ang-
dir” no campo “Name” e os valores “0” e “5” nos campos
“Minimum” e “Maximum”, respectivamente.

• Para a criação do parâmetro de Proximidade do objetivo, re-
pita o mesmo processo nomeando o parâmetro como “prox-
objetivo” e insira os valores “0” e “1” nos campos “Minimum”
e “Maximum”, respectivamente.

Figura 28: Criação de Parâmetros.

• Deverão ser criados Transitions Regions para que sejam de-
finidos momentos em que poderão haver mudanças na trilha
sonora de acordo com as ações do jogador. Para a criação de
um Transition region clique com o botão direito do mouse na
área preta logo abaixo da Timeline e posicione o cursor sobre
a opção Add Transtion Region To. Você então visualizará o
nome de todos os Markers criados anteriormente na figura 29.

Figura 29: Criação de Transition Regions.
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• Em seguida, clique na opção ”Viola” e posicione o Transition
Region criado logo abaixo do Loop Region abaixo do Marker
“Cello”, como pode ser visto na figura 30.

Figura 30: Posicionamento de Transition Region.

• Repita o processo para outros 9 Transition Regions seguindo
a disposição da figura 31:

Figura 31: Posicionamento de Transition Regions.

• Ao selecionar cada Transition Region você verá na região do
Deck o sı́mbolo +. Clique e selecione as opções Add Parame-
ter Condition e em seguida o parâmetro “ang-dir”.

Figura 32: Adicionando Parâmetro no Transition Region.

• No painel antes indicado como Trigger Conditions, na fi-
gura 33 você verá uma reta verde de valores entre 0.00 e 5.00,
da qual indica qual ou quais valores devem ser inseridos no
parâmetro “ang-dir” para que o som sofra alguma alteração.

• Dê um duplo clique no número “0.00” edigite “1” e dê duplo
clique no número “5.00” e digite “1” também.

Figura 33: Reta de valores em Trigger Conditions.

• Repita o processo nos outros Transition Regions inserindo os
seguintes valores:

Parâmetro: ang-dir
Valores: 1 a 5; sendo em ordem da esquerda para direita:

To Viola: 1-1 Efeito: somente Cello e Viola tocam.
To Vln 2: 2-2 Efeito: Cello + Viola + Violino 2.
To trans-Cello: 0-0.
To Vln 1: 3-3 Efeito: Cello + Viola + Violinos 1 e 2.
To trans-Viola: 1-1.
To Piano: 4-4 Efeito: Cello + Viola + Violinos 1 e 2 + Piano.
To trans-Vln 2: 2-2.
To Saı́da-sala: 5-5 - Tag indicando chegada ao objetivo.
To trans-Vln 1: 3-3.

• Em seguida crie transições clicando com o botão direito na
região abaixo da Timeline e selecione Transition To e Cello.

• Repita o mesmo processo para “To Viola-volta”, “To Vln 2-
volta” e “To Vln 1-volta” posicionando-os da seguinte forma:

• À seguir, deverão ser criadas linhas de automação para vo-
lume. Siga as orientações das imagens:

• Deverá ser criada uma linha de automação para o parâmetro
prox-objetivo. Porém, ao invés de criá-la na Timeline, clique
na aba prox-objetivo ao lado e crie a automação no canal “Pi-
ano” conforme demonstrado na imagem abaixo:

• Proximidade do Objetivo
Parâmetro: prox-objetivo Valores: 0 a 1

8 BANCO DE ÁUDIO E EXPORTAÇÃO DA BUILD
Uma vez que nós criamos esses eventos, devemos colocá-los em
um Banco de áudio. Para isso, no Event Editor, clique com o botão
direito sobre os eventos e escolha a opção Assign to Bank>Master
Bank. Por fim, vá ao menu File>Build, ou use o atalho Ctrl +Alt
+B. Para exportar as configurações de projeto para serem usados no
jogo.

9 INSTALAÇÃO DA API DE INTEGRAÇÃO COM
UNITY3D

Prosseguimos então com a integração da build gerada no FMOD
para trabalhar no Unity. Caso você não tenha nenhum conheci-
mento em Unity não precisa se preocupar, os passos de integração
são simples. Será necessário que você tenha instalado o Unity5
(link para download http://unity3d.com/pt/get-unity) em seu com-
putador e tenha seguido os passos do tutorial listados acima. O pro-
jeto de teste do jogo esta disponı́vel no link https://goo.gl/Opn9ip.

Figura 34: Adicionando valores em Trigger Conditions.
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Figura 35: Criação de Transição.

Figura 36: Criação e Posicionamento de Transições.

9.1 Instalação do FMOD Studio Unity Integration pac-
kage no Unity

1. Acesse o site http://www.fmod.org e procure no
menu superior o link ‘DOWNLOAD’ (link direto
http://www.fmod.org/download/)

2. Procure na pagina o tı́tulo FMOD Studio Unity Integration e
clique no botão ‘Download’ da primeira opção (Unity Inte-
gration for Windows/Mac/Linux/iOS/Android/WinPhone). A
versão do plugin FMOD Studio Unity Integration deve pos-
suir a mesma versão que o FMOD Studio. Caso não seja, você
pode baixar uma versão antiga no ultimo link dessa sessão ou
atualizar o seu FMOD para a mesma versão do package.

3. Abra o Unity5. Caso seja a sua primeira vez abrindo o Unity5
uma janela pedindo login será mostrada. Caso não tenha login

Figura 37: Criação de Automações de volume para Viola e Cello.

Figura 38: Automações de volume para Violinos I e II.

Figura 39: Automações de volume para Stinger do Vibrafone e Pi-
ano.

Figura 40: Automação de volume para Tag Saı́da da sala.

basta se cadastrar, o cadastro é gratuito. Na janela de seleção
de projetos selecione a opção ‘’OPEN’ na parte superior da
janela e em seguida selecione a pasta onde está o projeto do
tutorial descomprimido. Após isso clique em abrir.

4. Com o projeto aberto acesse Menu>Assets>Import
Package>Custom Package. Uma janela de importação
de assets irá aparecer. Selecione o FMOD Studio Unity
Integration baixado anteriormente (arquivo .unitypackage).

5. Na janela de Importing package selecione todas as opções de
arquivos e click no botão ‘Import’

6. Será adicionado uma série de arquivos ao projeto. Esses ar-
quivos são os responsáveis pela integração entre o FMOD
Studio e o Unity. Isso finaliza a instalação do FMOD Studio
Unity Integration package.

9.2 Importando banco
Após a instalação do Package está na hora de importar o banco de
áudios gerados no FMOD Studio para dentro do Unity. Caso você
ainda não tenha gerado a build veja a seção Exportar Builds do
FMOD Studio. Concluida a adição do plugin uma nova opção, de
nome FMOD, surgirá na barra de menus do Unity.

Acima você pode ver que o sub-menu FMOD dentro do menu
principal do Unity.

Selecione a opção FMOD>Edit Settings, na primeira seção,
presente na imagem abaixo, temos a integração do FMOD com
o Unity. Tal integração pode ser feita através de um projeto do
FMOD, caso esteja disponivel, ou na forma de builds especificas
para uma ou mais plataformas.
Este tutorial utilizará a opção de integração via projeto do FMOD,
será preciso informar os parâmetros de configuração necessários,
de acordo com as suas descrições e com a figura 45.
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Figura 41: Criação de Automações para Parâmetro de Proximidade.

Figura 42: Download do pacote de integração do FMOD Studio no
Unity.

Studio Project Path - Caminho em que se encontra o projeto
do FMOD.

Import Type - Controla como os assets serão importados
neste projeto.

• Streaming Assets - Copia os bancos do FMOD, do jeito
como foi gerado, para a pasta StreamingAssets. Dessa
forma podemos utilizar os bancos diretamente em tempo de
execução.

• Asset Bundle - Copia os bancos em um TextAsset do Unity,
que pode ser empacotado em um Asset Bundle, que pode ser
obtido separadamente do pacote principal. Caso esta forma
seja utilizada, o carregamento dos bancos de audio ficam sob
a responsabilidade dos scripts presentes no projeto.

FMOD Asset Folder - Diretorio de destino para as copias dos
bancos de audio, no formato TextAsset. Utilizado somente se o
Import Type for o de Asset Bundle.

A imagem à seguir lista as opções do plugin, existentes durante
a execução do projeto dentro da Unity.

Abaixo se encontram listadas breves explicações sobre cada
uma das opções presentes na imagem acima.
Load All Event Data at Initialization - Simplifica o gerencia-
mento dos bancos de audio, carregando todos os eventos, de todos
os bancos no inicio da execução.
Load All Sample Data at Initialization - Faz o mesmo que o
anterior, desta vez carregando todos os samples de audio.
Live Update - Permite a conexão com o jogo partindo do FMOD.
Debug Overlay - Mostra informações de debug na tela.
Bank Platform - Sub-diretorio a ser copiado para a pasta de
StreamingAssets. Baseia-se na plataforma do banco de audio.
Speaker Mode - Possibilita executar o mixer com uma
configuração de canais especifica.

Na imagem abaixo, apresentam-se as opções do plugin, similar
aos da figura anterior, relativas as builds que serão geradas pelo
Unity.

10 CHAMADAS DE SOM JOGO
O Unity FMOD Studio Unity Integration package já vem com al-
guns scripts e métodos preparados para agilizar a integração do
Unity com o FMOD.

Figura 43: Importando arquivos do pacote de Integração do FMOD
Studio.

Figura 44: Importando bancos de áudio gerados no FMOD Studio.

10.1 FMOD Studio Listener

O FMOD-Listener assume o mesmo papel que o Audio Listener
padrão do Unity. Ele é responsável por identificar o ponto onde está
o receptor de áudio do jogo (o jogador, ou até mesmo a câmera). É
extremamente importante que você tenha um, e apenas um, objeto
no Cenário com o Componente FMOD Studio Listener.
No nosso exemplo queremos que o ponto onde o áudio seja captu-
rado, o ponto onde será escutado o som do jogo, seja o jogador. No
nosso projeto abra a cena ‘Proto’, localizada na pasta ‘Scenes’. Na
aba Hierarchy do Unity selecione o Game Object chamado ‘Player’.
Após isso, na aba Inspector clique no botão ‘Add Component’ e
procure “FMOD Studio Listener” na caixa de busca.

Figura 45: Parâmetros de configuração do projeto FMOD no Unity.
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Figura 46: Opções do plugin FMOD Studio no Unity.

Figura 47: Opções do plugin FMOD Studio para builds geradas no
Unity.

10.2 FMOD Event Emitter

Outro componente muito importante que já vem disponı́vel no pa-
cote é o FMOD Studio Event Emitter. Com ele você conseguirá to-
car áudios do FMOD de forma simples. Selecione o objeto ‘Goal’
na cena ‘Proto’, em seguida na aba Inspector do Unity clique no
botão ‘Add Component’ e pesquise por “FMOD Studio Event Emit-
ter” na caixa de busca.

O componente FMOD Studio Event Emitter será adicionado ao
objetivo principal do jogo. Como você pode ver ele possui 3 pro-
priedades:

• Play Event: Propriedade responsavel por indicar em qual
evento o asset de audio deve ser executado.

• Stop Event: Similar ao Play Event, no entanto esta proprie-
dade é responsavel por indicar em qual evento o asset de audio
deve deixar de ser executado.

• Event: Nessa propriedade você deve especificar o asset do
áudio para o script. Para determinar qual asset você deseja
para o script basta clicar na luneta e realizar uma pesquisa por
nome entre os assets de audio. Alternativamente, é possivel
explorar a pasta do projeto do FMOD clicando no icone de
pasta.

Alem das 3 propriedades acima, é possivel inicializar os valo-
res dos parametros deste asset em Initial Parameter Values. Ainda
é possivel, dentro das opções avançadas, escolher as seguintes
opções:

• Preload Sample Data: O asset será carregado previamente a
sua execução.

• Allow Fadeout When Stoping: Quando o asset deixar de ser
executado, um fadeout ocorrerá.

• Trigger Once: O asset será executado uma única vez.

Figura 48: Adicionando componente FMOD Studio Listener.

Figura 49: Adicionando componente FMOD Studio Event Emitter.

Prosseguimos com o nosso tutorial. Vincule o asset de áudio
‘quarto/objetivos’ ao objetivo principal. Selecione “Level Start”
como o Play Event. Ao clicar no botão Play no centro superior
da janela do Unity percebemos que o áudio do jogo toca normal-
mente. Pare a execução do projeto, desfaça as alterações realizadas
e vamos para o próximo passo.

10.3 Implementação dos eventos no jogo e controle de
seus parâmetros

Com tudo ensinado até agora você consegue ter uma boa interação
entre a dinâmica de áudio do FMOD e o Unity, porém para avançar
e melhorar essas dinâmicas devemos aprender a usar os parâmetros
do FMOD.

10.4 FMODUnity.RuntimeManager.CreateInstance
Para termos um controle mas sofisticado sobre um deter-
minado asset do FMOD no Unity devemos criar o nosso
próprio script para coletar esse asset e controlar uma instância
de eventos. Para tanto podemos usar o método ‘FMODU-
nity.RuntimeManager.CreateInstance’, responsável por nos devol-
ver um EventInstance do asset de áudio, que por sua vez é res-
ponsável pelos eventos no áudio (Tocar, Pausar e Parar), bem como
mudança de parâmetros e atributos do áudio, como volume, pitch
etc.

Figura 50: Script para controlar eventos e parâmetros de áudio.

Salve o script (Ctrl+S) e volte para o projeto. Desative o com-
ponente FMOD Studio Event Emitter que havı́amos adicionado ao
objetivo anteriormente clicando na caixa de seleção que tem ao lado
do nome do componente. Isso é importante para que o nosso script
não gere um conflito tocando o mesmo audio que o FMOD Stu-
dio Event Emitter. Apos isso execute o jogo. Perceba que não há
diferença nenhuma na execução de áudio do jogo. Porém a cha-
mada de áudio agora esta sendo feita pelo nosso script, não mais
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pelo FMOD Studio Event Emitter. Pare a execução do projeto. Va-
mos entender o nosso código:

1. Primeiro criamos o atributo bg, na linha 16, que ficará res-
ponsável por guardar uma referência para o nosso asset.

2. No evento Start do Unity, que ocorre logo após quando o
Unity instancia o Game Object na cena, criamos:

• Na linha 40 uma chamada ao ’GetComponentInChil-
dren’ indicando o StudioEventEmitter como retorno.
Este metodo nos retornará um StudioEventEmitter que
será guardado na variavel ‘bg’

• Na linha 53 uma chamada ao ‘CreateInstance’ indi-
cando o path para o asset de áudio. O ‘CreateInstance’
nos devolverá uma EventInstance que será guardado no
atributo ‘chair’.

3. Depois de coletar nossos assets de audio, utilizamos:

• O método ‘start’, na linha 63, para a reprodução de um
EventInstance.

• O método ‘Play’, na linha 191, para a reprodução de um
StudioEventEmitter.

4. Para finalizar a reprodução de um asset de audio, usamos:

• O método ‘stop’, na linha 64, para um EventInstance.

• O método ‘Stop’, para um StudioEventEmitter.

10.5 Mudando parâmetros
Agora que possuı́mos o controle do evento do asset de áudio pode-
mos mudar parâmetros e realizar toda a dinâmica que foi pensada
para a musica no jogo. Primeiramente vamos observar as seguintes
linhas de código do nosso script ‘PlayerController.cs’.

Figura 51: Linhas do script PlayerController.

Neste codigo, temos:

1. Na linha 100 chamamos o método ‘setParameter’ para alterar
o valor de um parametro no asset de audio que é utilizado
por um StudioEventEmitter. Este método precisa de duas
informações, o nome do parametro definido no FMOD e o
valor que este parametro terá daqui para frente.

2. Já na linha 264, fazemos o mesmo que o item anterior. No en-
tanto, o metodo utilizado agora é o ‘setParameterValue’ pois
estamos lidando com um EventInstance.

10.6 Tocando, Parando e Pausando áudios
Outro recurso bastante importante a se aprender para trabalhar com
o FMOD no Unity é Parar, Pausar e Tocar o áudio a depender da
necessidade do seu projeto. Observando o codigo da figura 52, pre-
sente no ‘PlayerController’:

Utilizamos o método ‘getPlaybackState’ para saber o estado
atual da execução de um EventInstance. Os estados possiveis de
uma variavel deste tipo são:

1. PLAYING: Asset está sendo executado.

Figura 52: Script para controle de Playback.

2. STARTING: Preparando o asset para execução.

3. STOPPED: Asset está parado.

4. STOPPING: Preparando o asset para suspensão.

5. SUSTAINING: Pausando o asset.

Agora que sabemos qual o estado atual de um EventInstance,
podemos utilizar os metodos start(), stop() e setPaused() para, res-
pectivamente, tocar, parar e pausar o nosso asset. Finalizamos aqui
o básico deste tutorial. Para executar todo o gameplay do jogo exe-
cute o projeto novamente.

10.7 FMOD Live Update
O Live Update é recurso do FMOD Studio Unity Integration que
tras varias melhorias para as interações entre o Unity e o FMOD
Studio. Com ele você consegue acompanhar em jogo, em tempo
real, todas as modificações feitas nos assets de áudio no FMOD
Studio. Porem, por padrão, essa opção vem desativada no FMOD,
vamos aprender a usa-la.

1. Execute o projeto no Unity.

2. Agora no FMOD Studio e selecione a opção
Menu>File>Connect To Game. . . (F5). Uma janela
irá aparecer pedindo o endereço IP de acesso ao jogo.
Coloque o valor “localhost” e click no botão “Connect”.

Depois de seguir esses passos o FMOD Studio estará conectado
ao Jogo e as modificações feitas no Studio serão aplicadas direta-
mente no jogo. Muito importante lembrar que as modificações fei-
tas durante o Live Update serão perdidas no Unity, sendo necessário
no final gerar a build dos assets, conforme já foi ensinado.
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